using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[-+]?(?:0|[1-9](?:\d{0,2}(?:,\d{3})*|\d*))(?:\.\d+)?(?!\d)";
string input = @"12 +12 -12.0 -12,345.5466 +12,345,678,678 0.154
But not pass: 500. or 500, 500%";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}