import re
regex = re.compile(r"[-+]?(?:0|[1-9](?:\d{0,2}(?:,\d{3})*|\d*))(?:\.\d+)?(?!\d)", flags=re.MULTILINE)
test_str = ("12 +12 -12.0 -12,345.5466 +12,345,678,678 0.154\n"
"But not pass: 500. or 500, 500%")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")