import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[-+]?(?:0|[1-9](?:\\d{0,2}(?:,\\d{3})*|\\d*))(?:\\.\\d+)?(?!\\d)";
final String string = "12 +12 -12.0 -12,345.5466 +12,345,678,678 0.154\n"
+ "But not pass: 500. or 500, 500%";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}