re = /[-+]?(?:0|[1-9](?:\d{0,2}(?:,\d{3})*|\d*))(?:\.\d+)?(?!\d)/m
str = '12 +12 -12.0 -12,345.5466 +12,345,678,678 0.154
But not pass: 500. or 500, 500%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end