using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a\h*onclick=""javascript:do_things\(\'.*?\',\h*\')(.*)(\'\);"">)";
string input = @"<a onclick=""javascript:do_things('http://somelink.to.something.com', 'string'with'bad'quotes'');""> test');>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}