// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<a\h*onclick="javascript:do_things\(\'.*?\',\h*\')(.*)(\'\);">)"#).unwrap();
let string = "<a onclick=\"javascript:do_things('http://somelink.to.something.com', 'string'with'bad'quotes'');\"> test');>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}