re = /(<a\h*onclick="javascript:do_things\(\'.*?\',\h*\')(.*)(\'\);">)/
str = '<a onclick="javascript:do_things(\'http://somelink.to.something.com\', \'string\'with\'bad\'quotes\'\');"> test\');>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end