$re = '/(<a\h*onclick="javascript:do_things\(\'.*?\',\h*\')(.*)(\'\);">)/';
$str = '<a onclick="javascript:do_things(\'http://somelink.to.something.com\', \'string\'with\'bad\'quotes\'\');"> test\');>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);