using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\bsample|text\b)(?=[^>]*(<|$))";
string input = @"here is a sample text to test match <a href=""sample.html"">text sample here</a> text sample here <h1>sample text i do not want to match :(</h1>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}