re = /(\bsample|text\b)(?=[^>]*(<|$))/i
str = 'here is a sample text to test match <a href="sample.html">text sample here</a> text sample here <h1>sample text i do not want to match :(</h1>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end