$re = '/(\bsample|text\b)(?=[^>]*(<|$))/i';
$str = 'here is a sample text to test match <a href="sample.html">text sample here</a> text sample here <h1>sample text i do not want to match :(</h1>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);