const regex = /(\bsample|text\b)(?=[^>]*(<|$))/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\bsample|text\\b)(?=[^>]*(<|$))', 'gi')
const str = `here is a sample text to test match <a href="sample.html">text sample here</a> text sample here <h1>sample text i do not want to match :(</h1>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}