package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[1-9]\d{0,2}(?:\,\d{1,3})?$`)
var str = `100
999,0
999,999
999,99
-1
0
999,
999,9999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}