import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[1-9]\\d{0,2}(?:\\,\\d{1,3})?$";
final String string = "100\n"
+ "999,0\n"
+ "999,999\n"
+ "999,99\n\n"
+ "-1\n"
+ "0\n"
+ "999,\n"
+ "999,9999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}