const regex = /^[1-9]\d{0,2}(?:\,\d{1,3})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[1-9]\\d{0,2}(?:\\,\\d{1,3})?$', 'gm')
const str = `100
999,0
999,999
999,99
-1
0
999,
999,9999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}