package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(--\(\* vendor\(.*\), product\(.*?\))|(\*\)--)`)
var str = `select --(* vendor(microsoft), product(odbc) guid'12345678-1234-1234-1234-123456789012' *)-- from TAB
{Jane Doe?= --(* vendor(micro1macro2?), product(cdb!o) 123$% --(**) *)-- = ?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}