const regex = /(--\(\* vendor\(.*\), product\(.*?\))|(\*\)--)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(--\\(\\* vendor\\(.*\\), product\\(.*?\\))|(\\*\\)--)', 'gm')
const str = `select --(* vendor(microsoft), product(odbc) guid'12345678-1234-1234-1234-123456789012' *)-- from TAB
{Jane Doe?= --(* vendor(micro1macro2?), product(cdb!o) 123\$% --(**) *)-- = ?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}