const regex = new RegExp('(?!e\\d|\\\\n)[a-z](?<!\\\\n)', 'gm')
const str = `azjf8ee7Ldoge \\n Hmeqze= AZ12D Fs \\nsdfz14eZe148r `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);