import re
regex = re.compile(r"(?!e\d|\\n)[a-z](?<!\\n)", flags=re.MULTILINE)
test_str = "azjf8ee7Ldoge \\n Hmeqze= AZ12D Fs \\nsdfz14eZe148r "
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)