$re = '/(?!e\d|\\\\n)[a-z](?<!\\\\n)/m';
$str = 'azjf8ee7Ldoge \\n Hmeqze= AZ12D Fs \\nsdfz14eZe148r ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;