#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*\.java):(\d+): (.+): (.+)"
Local $sString = "Welcome.java:14: 错误: 找不到符号" & @CRLF & _
" InputFilter hexInputFilter()" & @CRLF & _
" ^" & @CRLF & _
" 符号: 类 InputFilter" & @CRLF & _
" 位置: 类 Welcome" & @CRLF & _
"Welcome.java:11: 错误: 程序包Systm不存在" & @CRLF & _
" Systm.out.println(g);" & @CRLF & _
" ^" & @CRLF & _
"Welcome.java:16: 错误: 找不到符号" & @CRLF & _
" return new InputFilter()" & @CRLF & _
" ^" & @CRLF & _
" 符号: 类 InputFilter" & @CRLF & _
" 位置: 类 Welcome" & @CRLF & _
"Welcome.java:45: 警告: Welcome.ClassWithOverridingMethod中的varargsMethod(String[])覆盖了Welcome.ClassWithVarargsMethod中的varargsMethod(String...); 覆盖的方法缺少 '...'" & @CRLF & _
" void varargsMethod(String[] s) { }" & @CRLF & _
" ^" & @CRLF & _
"3 个错误" & @CRLF & _
"1 个警告"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")