# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*\.java):(\d+): (.+): (.+)"
test_str = ("Welcome.java:14: 错误: 找不到符号\n"
" InputFilter hexInputFilter()\n"
" ^\n"
" 符号: 类 InputFilter\n"
" 位置: 类 Welcome\n"
"Welcome.java:11: 错误: 程序包Systm不存在\n"
" Systm.out.println(g);\n"
" ^\n"
"Welcome.java:16: 错误: 找不到符号\n"
" return new InputFilter()\n"
" ^\n"
" 符号: 类 InputFilter\n"
" 位置: 类 Welcome\n"
"Welcome.java:45: 警告: Welcome.ClassWithOverridingMethod中的varargsMethod(String[])覆盖了Welcome.ClassWithVarargsMethod中的varargsMethod(String...); 覆盖的方法缺少 '...'\n"
" void varargsMethod(String[] s) { }\n"
" ^\n"
"3 个错误\n"
"1 个警告")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.