const regex = /^(.*\.java):(\d+): (.+): (.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*\\.java):(\\d+): (.+): (.+)', 'gm')
const str = `Welcome.java:14: 错误: 找不到符号
InputFilter hexInputFilter()
^
符号: 类 InputFilter
位置: 类 Welcome
Welcome.java:11: 错误: 程序包Systm不存在
Systm.out.println(g);
^
Welcome.java:16: 错误: 找不到符号
return new InputFilter()
^
符号: 类 InputFilter
位置: 类 Welcome
Welcome.java:45: 警告: Welcome.ClassWithOverridingMethod中的varargsMethod(String[])覆盖了Welcome.ClassWithVarargsMethod中的varargsMethod(String...); 覆盖的方法缺少 '...'
void varargsMethod(String[] s) { }
^
3 个错误
1 个警告`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}