import Foundation
let pattern = #"^(.*\.java):(\d+): (.+): (.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Welcome.java:14: 错误: 找不到符号
InputFilter hexInputFilter()
^
符号: 类 InputFilter
位置: 类 Welcome
Welcome.java:11: 错误: 程序包Systm不存在
Systm.out.println(g);
^
Welcome.java:16: 错误: 找不到符号
return new InputFilter()
^
符号: 类 InputFilter
位置: 类 Welcome
Welcome.java:45: 警告: Welcome.ClassWithOverridingMethod中的varargsMethod(String[])覆盖了Welcome.ClassWithVarargsMethod中的varargsMethod(String...); 覆盖的方法缺少 '...'
void varargsMethod(String[] s) { }
^
3 个错误
1 个警告
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)