using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[ ]{4}(.*)(?!=^[ ]{4})";
string substitution = @"<pre>$1</pre>";
string input = @"Here is the code:
String name = ""Jon"";
System.out.println(""Hello ""+name);
output:
Hello Jon";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}