re = /^[ ]{4}(.*)(?!=^[ ]{4})/m
str = 'Here is the code:
String name = "Jon";
System.out.println("Hello "+name);
output:
Hello Jon'
subst = '<pre>$1</pre>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result