$re = '/^[ ]{4}(.*)(?!=^[ ]{4})/m';
$str = 'Here is the code:
String name = "Jon";
System.out.println("Hello "+name);
output:
Hello Jon';
$subst = "<pre>$1</pre>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;