use strict;
my $str = 'Here is the code:
String name = "Jon";
System.out.println("Hello "+name);
output:
Hello Jon';
my $regex = qr/^[ ]{4}(.*)(?!=^[ ]{4})/mp;
my $subst = '<pre>$1</pre>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";