#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<p>\s*(https?:\/\/(?:(?!<\/?p>).)+)\s*<\/p>"
Local $sString = "<p>http://youtube.com/</p>" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/watch?v=mwottkiniuY"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")