re = /<p>\s*(https?:\/\/(?:(?!<\/?p>).)+)\s*<\/p>/
str = '<p>http://youtube.com/</p>
https://www.youtube.com/watch?v=mwottkiniuY'
# Print the match result
str.match(re) do |match|
puts match.to_s
end