const regex = /<p>\s*(https?:\/\/(?:(?!<\/?p>).)+)\s*<\/p>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<p>\\s*(https?:\\\/\\\/(?:(?!<\\\/?p>).)+)\\s*<\\\/p>', '')
const str = `<p>http://youtube.com/</p>
https://www.youtube.com/watch?v=mwottkiniuY`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}