const regex = /(?<!\S)(@\S+|\d+)(?:\s+(?1))*(?=\s*$)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)(@\\S+|\\d+)(?:\\s+(?1))*(?=\\s*$)', '')
const str = `hello @tag1 111 world @tag2 @tag3 222 333`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}