import re
regex = re.compile(r"(?<!\S)(@\S+|\d+)(?:\s+(?1))*(?=\s*$)")
test_str = "hello @tag1 111 world @tag2 @tag3 222 333"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")