re = /(?<!\S)(@\S+|\d+)(?:\s+(?1))*(?=\s*$)/
str = 'hello @tag1 111 world @tag2 @tag3 222 333'
# Print the match result
str.match(re) do |match|
puts match.to_s
end