$re = '/(?<!\S)(@\S+|\d+)(?:\s+(?1))*(?=\s*$)/';
$str = 'hello @tag1 111 world @tag2 @tag3 222 333';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);