const regex = new RegExp('\\W+', 'gm')
const str = `Street # 453, XYZ - Road. / City, State.
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);