$re = '~\W+~m';
$str = 'Street # 453, XYZ - Road. / City, State.
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;