re = /\W+/m
str = 'Street # 453, XYZ - Road. / City, State.
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result