use strict;
my $str = 'Street # 453, XYZ - Road. / City, State.
';
my $regex = qr~\W+~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";