use strict;
my $str = '<img src="https://exemplo.files.wordpress.com/2018/04/30656289_1739197086123960_7879125475971301376_o.jpg">';
my $regex = qr/src\="https:\/\/exemplo\.files\.wordpress\.com(.*?)"/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}