re = /src\="https:\/\/exemplo\.files\.wordpress\.com(.*?)"/
str = '<img src="https://exemplo.files.wordpress.com/2018/04/30656289_1739197086123960_7879125475971301376_o.jpg">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end