package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{4}\s\S.+`)
var str = `1234 abc line abc beach
123 abc road abc beach FL 12345-1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}