re = /\d{4}\s\S.+/m
str = '1234 abc line abc beach
123 abc road abc beach FL 12345-1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end