const regex = /\d{4}\s\S.+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{4}\\s\\S.+', 'gm')
const str = `1234 abc line abc beach
123 abc road abc beach FL 12345-1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}