using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:'(\w+)|\G(?<!^))(?:;(\w+)=(\w+))?(?::([^']*)'.*$)?";
string input = @"$subject = 'name:content' ;
$subject = 'name;param1=value1:content' ;
$subject = 'name;param11=value11;param21=value21:content' ;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}