$re = '/(?:\'(\w+)|\G(?<!^))(?:;(\w+)=(\w+))?(?::([^\']*)\'.*$)?/m';
$str = '$subject = \'name:content\' ;
$subject = \'name;param1=value1:content\' ;
$subject = \'name;param11=value11;param21=value21:content\' ;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);