import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:'(\\w+)|\\G(?<!^))(?:;(\\w+)=(\\w+))?(?::([^']*)'.*$)?";
final String string = "$subject = 'name:content' ;\n"
+ "$subject = 'name;param1=value1:content' ;\n"
+ "$subject = 'name;param11=value11;param21=value21:content' ;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}