using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?<tag>\w+)(?:\s+(?<attrs>.*?))?>(?<content>.*)<\/\1>";
string input = @"<p id=""12"">Hello </h> </p>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}