re = /<(?<tag>\w+)(?:\s+(?<attrs>.*?))?>(?<content>.*)<\/\1>/
str = '<p id="12">Hello </h> </p>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end