const regex = /<(?<tag>\w+)(?:\s+(?<attrs>.*?))?>(?<content>.*)<\/\1>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?<tag>\\w+)(?:\\s+(?<attrs>.*?))?>(?<content>.*)<\\\/\\1>', '')
const str = `<p id="12">Hello </h> </p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}